Vital Information on This Issue
Vulnerabilities in Apache Running Version Prior to 2.2.23 is a Medium risk vulnerability that is one of the most frequently found on networks around the world. This issue has been around since at least 1990 but has proven either difficult to detect, difficult to resolve or prone to being overlooked entirely.
|Vulnerability Name:||Apache Running Version Prior to 2.2.23|
|Summary:|| Multiple vulnerabilities have been discovered in Apache:
* envvars (aka envvars-std) in the Apache HTTP Server before 2.4.2 places a zero-length directory name in the LD_LIBRARY_PATH, which allows local users to gain privileges via a Trojan horse DSO in the current working directory during execution of apachectl.
* Multiple cross-site scripting (XSS) vulnerabilities in the make_variant_list function in mod_negotiation.c in the mod_negotiation module in the Apache HTTP Server 2.4.x before 2.4.3, when the MultiViews option is enabled, allow remote attackers to inject arbitrary web script or HTML via a crafted filename that is not properly handled during construction of a variant list.
|Impact:||Allow remote attackers to inject arbitrary web script or HTML via a crafted filename that is not properly handled during construction of a variant list.|
|Solution:||Upgrade to Apache version 2.2.23 or newer.|
|Nist NVD (CVSS):||AV:L/AC:M/Au:N/C:C/I:C/A:C|
Scanning For and Finding Vulnerabilities in Apache Running Version Prior to 2.2.23
Use of Vulnerability Management tools, like AVDS, are standard practice for the discovery of this vulnerability. The primary failure of VA in finding this vulnerability is related to setting the proper scope and frequency of network scans. It is vital that the broadest range of hosts (active IPs) possible are scanned and that scanning is done frequently. We recommend weekly. Your existing scanning solution or set of test tools should make this not just possible, but easy and affordable. If that is not the case, please consider AVDS.
Penetration Testing (pentest) for this Vulnerability
The Vulnerabilities in Apache Running Version Prior to 2.2.23 is prone to false positive reports by most vulnerability assessment solutions. AVDS is alone in using behavior based testing that eliminates this issue. For all other VA tools security consultants will recommend confirmation by direct observation. In any case Penetration testing procedures for discovery of Vulnerabilities in Apache Running Version Prior to 2.2.23 produces the highest discovery accuracy rate, but the infrequency of this expensive form of testing degrades its value. The ideal would be to have pentesting accuracy and the frequency and scope possibilities of VA solutions, and this is accomplished only by AVDS.
Security Updates on Vulnerabilities in Apache Running Version Prior to 2.2.23
For the most current updates on this vulnerability please check www.securiteam.com Given that this is one of the most frequently found vulnerabilities, there is ample information regarding mitigation online and very good reason to get it fixed. Hackers are also aware that this is a frequently found vulnerability and so its discovery and repair is that much more important. It is so well known and common that any network that has it present and unmitigated indicates "low hanging fruit" to attackers.
Confirming the Presence of Vulnerabilities in Apache Running Version Prior to 2.2.23
AVDS is currently testing for and finding this vulnerability with zero false positives. If your current set of tools is indicating that it is present but you think it is probably a false positive, please contact us for a demonstration of AVDS.
The secret killer of VA solution value is the false positive. There was an industry wide race to find the most vulnerabilities, including Vulnerabilities in Apache Running Version Prior to 2.2.23 ,and this resulted in benefit to poorly written tests that beef up scan reports by adding a high percentage of uncertainty. This may have sold a lot of systems some years ago, but it also stuck almost all VA solutions with deliberately inaccurate reporting that adds time to repairs that no administrator can afford. Beyond Security did not participate in this race to mutually assured destruction of the industry and to this day produces the most accurate and actionable reports available.
Exploits related to Vulnerabilities in Apache Running Version Prior to 2.2.23
Please also visit www.securiteam.com to view any exploits available for this vulnerability, or search using "Vulnerabilities in Apache Running Version Prior to 2.2.23".