Finding and Fixing Vulnerabilities in Apache Running Version Prior to 2.2.28, a High Risk Vulnerability

With Notes on Remediation, Penetration Testing, Disclosures, Patching and Exploits

Contents

  • Vital information on this issue
  • Scanning For and Finding Vulnerabilities in Apache Running Version Prior to 2.2.28
  • Penetration Testing (Pentest) for this Vulnerability
  • Security updates on Vulnerabilities in Apache Running Version Prior to 2.2.28
  • Disclosures related to Vulnerabilities in Apache Running Version Prior to 2.2.28
  • Confirming the Presence of Vulnerabilities in Apache Running Version Prior to 2.2.28
  • False positive/negatives
  • Patching/Repairing this vulnerability
  • Exploits related to Vulnerabilities in Apache Running Version Prior to 2.2.28

Vital Information on This Issue
Vulnerabilities in Apache Running Version Prior to 2.2.28 is a high risk vulnerability that is one of the most frequently found on networks around the world. This issue has been around since at least 1990 but has proven either difficult to detect, difficult to resolve or prone to being overlooked entirely.


Vulnerability Name: Vulnerabilities in Apache Running Version Prior to 2.2.28
Test ID: 17584
Risk: High
Category: Web servers
Type: Attack
Summary: Multiple vulnerabilities have been found in Apache: * The mod_headers module in the Apache HTTP Server 2.2.22 allows remote attackers to bypass RequestHeader unset directives by placing a header in the trailer portion of data sent with chunked transfer coding. NOTE: the vendor states this is not a security issue in httpd as such. * The deflate_in_filter function in mod_deflate.c in the mod_deflate module in the Apache HTTP Server before 2.4.10, when request body decompression is enabled, allows remote attackers to cause a denial of service (resource consumption) via crafted request data that decompresses to a much larger size. * Race condition in the mod_status module in the Apache HTTP Server before 2.4.10 allows remote attackers to cause a denial of service (heap-based buffer overflow), or possibly obtain sensitive credential information or execute arbitrary code, via a crafted request that triggers improper scoreboard handling within the status_handler function in modules/generators/mod_status.c and the lua_ap_scoreboard_worker function in modules/lua/lua_request.c. * The mod_cgid module in the Apache HTTP Server before 2.4.10 does not have a timeout mechanism, which allows remote attackers to cause a denial of service (process hang) via a request to a CGI script that does not read from its stdin file descriptor.
Impact: Execute Arbitrary Code/Commands, Denial of Service and Reduced Security.
Solution: Upgrade to Apache version version 2.2.29 or newer.
CVE: CVE-2013-5704
CVE-2014-0118
CVE-2014-0226
CVE-2014-0231
More Information: http://httpd.apache.org/security/vulnerabilities_22.html
http://martin.swende.se/blog/HTTPChunked.html
http://www.zerodayinitiative.com/advisories/ZDI-14-236/
Nist NVD (CVSS): (AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Score: 6.8
For more information on this also issue see: www.securiteam.com

Scanning For and Finding Vulnerabilities in Apache Running Version Prior to 2.2.28
Use of Vulnerability Management tools, like AVDS, are standard practice for the discovery of this vulnerability. The primary failure of VA in finding this vulnerability is related to setting the proper scope and frequency of network scans. It is vital that the broadest range of hosts (active IPs) possible are scanned and that scanning is done frequently. We recommend weekly. Your existing scanning solution or set of test tools should make this not just possible, but easy and affordable. If that is not the case, please consider AVDS.

Penetration Testing (pentest) for this Vulnerability
The Vulnerabilities in Apache Running Version Prior to 2.2.28 is prone to false positive reports by most vulnerability assessment solutions. AVDS is alone in using behavior based testing that eliminates this issue. For all other VA tools security consultants will recommend confirmation by direct observation. In any case Penetration testing procedures for discovery of Vulnerabilities in Apache Running Version Prior to 2.2.28 produces the highest discovery accuracy rate, but the infrequency of this expensive form of testing degrades its value. The ideal would be to have pentesting accuracy and the frequency and scope possibilities of VA solutions, and this is accomplished only by AVDS.

Security Updates on Vulnerabilities in Apache Running Version Prior to 2.2.28
For the most current updates on this vulnerability please check www.securiteam.com Given that this is one of the most frequently found vulnerabilities, there is ample information regarding mitigation online and very good reason to get it fixed. Hackers are also aware that this is a frequently found vulnerability and so its discovery and repair is that much more important. It is so well known and common that any network that has it present and unmitigated indicates "low hanging fruit" to attackers.

Disclosures related to this vulnerability
http://httpd.apache.org/security/vulnerabilities_22.html
https://oss.oracle.com/ol6/docs/RELEASE-NOTES-U6-en.html
http://httpd.apache.org/docs/2.2/mod/mod_deflate.html
http://blog.gmane.org/gmane.comp.apache.announce

Confirming the Presence of Vulnerabilities in Apache Running Version Prior to 2.2.28
AVDS is currently testing for and finding this vulnerability with zero false positives. If your current set of tools is indicating that it is present but you think it is probably a false positive, please contact us for a demonstration of AVDS.

False positive/negatives
The secret killer of VA solution value is the false positive. There was an industry wide race to find the most vulnerabilities, including Vulnerabilities in Apache Running Version Prior to 2.2.28 ,and this resulted in benefit to poorly written tests that beef up scan reports by adding a high percentage of uncertainty. This may have sold a lot of systems some years ago, but it also stuck almost all VA solutions with deliberately inaccurate reporting that adds time to repairs that no administrator can afford. Beyond Security did not participate in this race to mutually assured destruction of the industry and to this day produces the most accurate and actionable reports available.

Patching/Repairing this Vulnerability
https://httpd.apache.org/download.cgi Vulnerabilities in Apache Running Version Prior to 2.2.28 is a high risk vulnerability that is also high frequency and high visibility. This is the most severe combination of security factors that exists and it is extremely important to find it on your network and fix it as soon as possible.

Exploits related to Vulnerabilities in Apache Running Version Prior to 2.2.28
https://www.cvedetails.com
https://www.exploit-db.com/exploits/11650/

Please also visit www.securiteam.com to view any exploits available for this vulnerability, or search using "Vulnerabilities in Apache Running Version Prior to 2.2.28".


Print Friendly and PDF