- Vital information on this issue
- Scanning For and Finding OpenSSL Running Version Prior to 0.9.8zc (POODLE)
- Penetration Testing (Pentest) for this Vulnerability
- Security updates on OpenSSL Running Version Prior to 0.9.8zc (POODLE)
- Disclosures related to OpenSSL Running Version Prior to 0.9.8zc (POODLE)
- Confirming the Presence of OpenSSL Running Version Prior to 0.9.8zc (POODLE)
- False positive/negatives
- Patching/Repairing this vulnerability
- Exploits related to OpenSSL Running Version Prior to 0.9.8zc (POODLE)
Vital Information on This Issue
OpenSSL Running Version Prior to 0.9.8zc (POODLE) is a high risk vulnerability that is one of the most frequently found on networks around the world. This issue has been around since at least 1990 but has proven either difficult to detect, difficult to resolve or prone to being overlooked entirely.
|Vulnerability Name:||OpenSSL Running Version Prior to 0.9.8zc (POODLE)|
|Category:||Encryption and Authentication|
|Summary:||Multiple vulnerabilities have been found in OpenSSL: * The SSL protocol 3.0, as used in OpenSSL through 1.0.1i and other products, uses nondeterministic CBC padding, which makes it easier for man in the middle attackers to obtain cleartext data via a padding-oracle attack, aka the ” POODLE” issue. * Memory leak in the tls_decrypt_ticket function in t1_lib.c in OpenSSL before 0.9.8zc, 1.0.0 before 1.0.0o, and 1.0.1 before 1.0.1j allows remote attackers to cause a denial of service (memory consumption) via a crafted session ticket that triggers an integrity-check failure. * OpenSSL before 0.9.8zc, 1.0.0 before 1.0.0o, and 1.0.1 before 1.0.1j does not properly enforce the no-ssl3 build option, which allows remote attackers to bypass intended access restrictions via an SSL 3.0 handshake, related to s23_clnt.c and s23_srvr.c.|
|Impact:||The POODLE attack can be used against any browser or website that supports SSLv3. This affects all current browsers and most websites. As noted above, only 0.3 percent of transactions actually use SSLv3. Though almost all websites allow connections with SSLv3 to support old browsers, it is rarely used, since there are very few browsers that don’t support newer versions of TLS. Sites that require SSLv3 will remain vulnerable until they upgrade to a more recent version of TLS.|
|Solution:||Upgrade to OpenSSL version 0.9.8zc or newer.|
|Nist NVD (CVSS):||AV:N/AC:M/Au:N/C:N/I:N/A:C
Scanning For and Finding OpenSSL Running Version Prior to 0.9.8zc (POODLE)
Use of Vulnerability Management tools, like AVDS, are standard practice for the discovery of this vulnerability. The primary failure of VA in finding this vulnerability is related to setting the proper scope and frequency of network scans. It is vital that the broadest range of hosts (active IPs) possible are scanned and that scanning is done frequently. We recommend weekly. Your existing scanning solution or set of test tools should make this not just possible, but easy and affordable. If that is not the case, please consider AVDS.
Penetration Testing (pentest) for this Vulnerability
The OpenSSL Running Version Prior to 0.9.8zc (POODLE)is prone to false positive reports by most vulnerability assessment solutions. AVDS is alone in using behavior based testing that eliminates this issue. For all other VA tools security consultants will recommend confirmation by direct observation. In any case Penetration testing procedures for discovery of [name] produces the highest discovery accuracy rate, but the infrequency of this expensive form of testing degrades its value. The ideal would be to have pentesting accuracy and the frequency and scope possibilities of VA solutions, and this is accomplished only by AVDS.
Security Updates on OpenSSL Running Version Prior to 0.9.8zc (POODLE)
Given that this is one of the most frequently found vulnerabilities, there is ample information regarding mitigation online and very good reason to get it fixed. Hackers are also aware that this is a frequently found vulnerability and so its discovery and repair is that much more important. It is so well known and common that any network that has it present and unmitigated indicates “low hanging fruit” to attackers.
Disclosures related to this vulnerability
Confirming the Presence of OpenSSL Running Version Prior to 0.9.8zc (POODLE)
AVDS is currently testing for and finding this vulnerability with zero false positives. If your current set of tools is indicating that it is present but you think it is probably a false positive, please contact us for a demonstration of AVDS.
The secret killer of VA solution value is the false positive. There was an industry wide race to find the most vulnerabilities, including OpenSSL Running Version Prior to 0.9.8zc (POODLE) ,and this resulted in benefit to poorly written tests that beef up scan reports by adding a high percentage of uncertainty. This may have sold a lot of systems some years ago, but it also stuck almost all VA solutions with deliberately inaccurate reporting that adds time to repairs that no administrator can afford. Beyond Security did not participate in this race to mutually assured destruction of the industry and to this day produces the most accurate and actionable reports available.
Patching/Repairing this Vulnerability
http://www.openssh.com/ OpenSSL Running Version Prior to 0.9.8zc (POODLE) is a high risk vulnerability that is also high frequency and high visibility. This is the most severe combination of security factors that exists and it is extremely important to find it on your network and fix it as soon as possible.