- Vital information on this issue
- Scanning For and Finding PHP Running Version Prior to 5.2.15
- Penetration Testing (Pentest) for this Vulnerability
- Security updates on PHP Running Version Prior to 5.2.15
- Disclosures related to PHP Running Version Prior to 5.2.15
- Confirming the Presence of PHP Running Version Prior to 5.2.15
- False positive/negatives
- Patching/Repairing this vulnerability
- Exploits related to PHP Running Version Prior to 5.2.15
Vital Information on This Issue
PHP Running Version Prior to 5.2.15 is a high risk vulnerability that is one of the most frequently found on networks around the world. This issue has been around since at least 1990 but has proven either difficult to detect, difficult to resolve or prone to being overlooked entirely.
|Vulnerability Name:||PHP Running Version Prior to 5.2.15|
|Category:||Server Side Scripts|
|Summary:||Multiple vulnerabilities have been found in PHP: * The ZipArchive::getArchiveComment function in PHP 5.2.x through 5.2.14 and 5.3.x through 5.3.3 allows context-dependent attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted ZIP archive. * fopen_wrappers.c in PHP 5.3.x through 5.3.3 might allow remote attackers to bypass open_basedir restrictions via vectors related to the length of a filename. * Double free vulnerability in the imap_do_open function in the IMAP extension (ext/imap/php_imap.c) in PHP 5.2 before 5.2.15 and 5.3 before 5.3.4 allows attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via unspecified vectors.|
|Solution:||See solution provided at: Upgrade to PHP version 5.2.15 or newer. https://secure.php.net/releases/|
|Nist NVD (CVSS):||(AV:N/AC:L/Au:N/C:N/I:P/A:N)|
Scanning For and Finding PHP Running Version Prior to 5.2.15
Use of Vulnerability Management tools, like AVDS, are standard practice for the discovery of this vulnerability. The primary failure of VA in finding this vulnerability is related to setting the proper scope and frequency of network scans. It is vital that the broadest range of hosts (active IPs) possible are scanned and that scanning is done frequently. We recommend weekly. Your existing scanning solution or set of test tools should make this not just possible, but easy and affordable. If that is not the case, please consider AVDS.
Penetration Testing (pentest) for this Vulnerability
The PHP Running Version Prior to 5.2.15 is prone to false positive reports by most vulnerability assessment solutions. AVDS is alone in using behavior based testing that eliminates this issue. For all other VA tools security consultants will recommend confirmation by direct observation. In any case Penetration testing procedures for discovery of PHP Running Version Prior to 5.2.15 produces the highest discovery accuracy rate, but the infrequency of this expensive form of testing degrades its value. The ideal would be to have pentesting accuracy and the frequency and scope possibilities of VA solutions, and this is accomplished only by AVDS.
Security Updates on PHP Running Version Prior to 5.2.15
For the most current updates on this vulnerability please check www.securiteam.com Given that this is one of the most frequently found vulnerabilities, there is ample information regarding mitigation online and very good reason to get it fixed. Hackers are also aware that this is a frequently found vulnerability and so its discovery and repair is that much more important. It is so well known and common that any network that has it present and unmitigated indicates "low hanging fruit" to attackers.
Disclosures related to this vulnerability
Confirming the Presence of PHP Running Version Prior to 5.2.15
AVDS is currently testing for and finding this vulnerability with zero false positives. If your current set of tools is indicating that it is present but you think it is probably a false positive, please contact us for a demonstration of AVDS.
The secret killer of VA solution value is the false positive. There was an industry wide race to find the most vulnerabilities, including PHP Running Version Prior to 5.2.15,and this resulted in benefit to poorly written tests that beef up scan reports by adding a high percentage of uncertainty. This may have sold a lot of systems some years ago, but it also stuck almost all VA solutions with deliberately inaccurate reporting that adds time to repairs that no administrator can afford. Beyond Security did not participate in this race to mutually assured destruction of the industry and to this day produces the most accurate and actionable reports available.
Patching/Repairing this Vulnerability
https://secure.php.net/releases/ PHP Running Version Prior to 5.2.15 is a high risk vulnerability that is also high frequency and high visibility. This is the most severe combination of security factors that exists and it is extremely important to find it on your network and fix it as soon as possible.
Exploits related to PHP Running Version Prior to 5.2.15
Allows attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via unspecified vectors. https://secure.php.net
Please also visit www.securiteam.com to view any exploits available for this vulnerability, or search using "PHP Running Version Prior to 5.2.15 exploits".