Contents

  • Vital information on this issue
  • Scanning For and Finding Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za
  • Penetration Testing (Pentest) for this Vulnerability
  • Security updates on Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za
  • Disclosures related to Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za
  • Confirming the Presence of Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za
  • False positive/negatives
  • Patching/Repairing this vulnerability
  • Exploits related to Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za

 

Vital Information on This Issue
Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za is a Medium risk vulnerability that is one of the most frequently found on networks around the world. This issue has been around since at least 1990 but has proven either difficult to detect, difficult to resolve or prone to being overlooked entirely.

 

Vulnerability Name: OpenSSL Running Version Prior to 0.9.8za
Test ID: 16645
Risk: Medium
Category: Encryption and Authentication
Type: Attack
Summary: Multiple vulnerabilities have been found in OpenSSL:
* The Montgomery ladder implementation in OpenSSL through 1.0.0l does not ensure that certain swap operations have a constant-time behavior, which makes it easier for local users to obtain ECDSA nonces via a FLUSH+RELOAD cache side-channel attack.

* The dtls1_reassemble_fragment function in d1_both.c in OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly validate fragment lengths in DTLS ClientHello messages, which allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a long non-initial fragment.

* The dtls1_get_message_fragment function in d1_both.c in OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h allows remote attackers to cause a denial of service (recursion and client crash) via a DTLS hello message in an invalid DTLS handshake.

* OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly restrict processing of ChangeCipherSpec messages, which allows man-in-the-middle attackers to trigger use of a zero-length master key in certain OpenSSL-to-OpenSSL communications, and consequently hijack sessions or obtain sensitive information, via a crafted TLS handshake, aka the "CCS Injection" vulnerability.

* The ssl3_send_client_key_exchange function in s3_clnt.c in OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h, when an anonymous ECDH cipher suite is used, allows remote attackers to cause a denial of service (NULL pointer dereference and client crash) by triggering a NULL certificate value.
$OUTPUT

Impact: Local users can obtain ECDSA nonces via a FLUSH+RELOAD cache side-channel attack,

allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a long non-initial fragment,

allows remote attackers to cause a denial of service (recursion and client crash) via a DTLS hello message in an invalid DTLS handshake,

allows man-in-the-middle attackers to trigger use of a zero-length master key in certain OpenSSL-to-OpenSSL communications,

and allows remote attackers to cause a denial of service (NULL pointer dereference and client crash) by triggering a NULL certificate value.

Solution: Upgrade to OpenSSL version 0.9.8za or newer.
CVE: CVE-2014-0076

CVE-2014-0195

CVE-2014-0221

CVE-2014-0224

CVE-2014-3470

More Information: https://www.imperialviolet.org/2014/06/05/earlyccs.html

https://support.apple.com/en-us/HT204532

http://support.blackberry.com/kb/articleDetail?ArticleNumber=000036051

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20140605-openssl

Nist NVD (CVSS): AV:N/AC:M/Au:N/C:P/I:P/A:P
CVSS Score: 6.8
For more information on this also issue see: www.securiteam.com 

Scanning For and Finding Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za
Use of Vulnerability Management tools, like AVDS, are standard practice for the discovery of this vulnerability. The primary failure of VA in finding this vulnerability is related to setting the proper scope and frequency of network scans. It is vital that the broadest range of hosts (active IPs) possible are scanned and that scanning is done frequently. We recommend weekly. Your existing scanning solution or set of test tools should make this not just possible, but easy and affordable. If that is not the case, please consider AVDS.

Penetration Testing (pentest) for this Vulnerability
The Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za is prone to false positive reports by most vulnerability assessment solutions. AVDS is alone in using behavior based testing that eliminates this issue. For all other VA tools security consultants will recommend confirmation by direct observation. In any case Penetration testing procedures for discovery of Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za produces the highest discovery accuracy rate, but the infrequency of this expensive form of testing degrades its value. The ideal would be to have pentesting accuracy and the frequency and scope possibilities of VA solutions, and this is accomplished only by AVDS.

Security Updates on Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za
For the most current updates on this vulnerability please check www.securiteam.com Given that this is one of the most frequently found vulnerabilities, there is ample information regarding mitigation online and very good reason to get it fixed. Hackers are also aware that this is a frequently found vulnerability and so its discovery and repair is that much more important. It is so well known and common that any network that has it present and unmitigated indicates "low hanging fruit" to attackers.

Disclosures related to this vulnerability
http://seclists.org/fulldisclosure/2014/Dec/23

Confirming the Presence of Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za
AVDS is currently testing for and finding this vulnerability with zero false positives. If your current set of tools is indicating that it is present but you think it is probably a false positive, please contact us for a demonstration of AVDS. 

False positive/negatives
The secret killer of VA solution value is the false positive. There was an industry wide race to find the most vulnerabilities, including Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za ,and this resulted in benefit to poorly written tests that beef up scan reports by adding a high percentage of uncertainty. This may have sold a lot of systems some years ago, but it also stuck almost all VA solutions with deliberately inaccurate reporting that adds time to repairs that no administrator can afford. Beyond Security did not participate in this race to mutually assured destruction of the industry and to this day produces the most accurate and actionable reports available.

Patching/Repairing this Vulnerability

Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za is a Medium risk vulnerability that is also high frequency and high visibility. This is the most severe combination of security factors that exists and it is extremely important to find it on your network and fix it as soon as possible.

 

Exploits related to Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za
http://www14.software.ibm.com/webapp/set2/subscriptions/pqvcmjd?mode=18&ID=6060&myns=phmc&mync=E
http://www.splunk.com/view/SP-CAAAM2D
http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00027.html

Please also visit www.securiteam.com to view any exploits available for this vulnerability, or search using "Vulnerabilities in OpenSSL Running Version Prior to 0.9.8za".