- Vital information on this issue
- Scanning For and Finding Vulnerabilities in Apache Running Version Prior to 2.2.25
- Penetration Testing (Pentest) for this Vulnerability
- Security updates on Vulnerabilities in Apache Running Version Prior to 2.2.25
- Disclosures related to Vulnerabilities in Apache Running Version Prior to 2.2.25
- Confirming the Presence of Vulnerabilities in Apache Running Version Prior to 2.2.25
- False positive/negatives
- Patching/Repairing this vulnerability
- Exploits related to Vulnerabilities in Apache Running Version Prior to 2.2.25
Vital Information on Apache Vulnerability
Vulnerabilities in Apache Running Version Prior to 2.2.25 is a Medium risk vulnerability that is one of the most frequently found on networks around the world. This issue has been around since at least 1990 but has proven either difficult to detect, difficult to resolve or prone to being overlooked entirely.
|Apache Running Version Prior to 2.2.25
|Multiple vulnerabilities have been found in Apache: * mod_rewrite.c in the mod_rewrite module in the Apache HTTP Server 2.2.x before 2.2.25 writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to execute arbitrary commands via an HTTP request containing an escape sequence for a terminal emulator.
* mod_dav.c in the Apache HTTP Server before 2.2.25 does not properly determine whether DAV is enabled for a URI, which allows remote attackers to cause a denial of service (segmentation fault) via a MERGE request in which the URI is configured for handling by the mod_dav_svn module, but a certain href attribute in XML data refers to a non-DAV URI.
Upgrade to Apache version 2.2.24 or newer.
|Nist NVD (CVSS):
Scanning for and Finding Vulnerabilities in Apache Running Version Prior to 2.2.25
Use of Vulnerability Management tools, like AVDS, are standard practice for the discovery of this vulnerability. The primary failure of VA in finding this vulnerability is related to setting the proper scope and frequency of network scans. It is vital that the broadest range of hosts (active IPs) possible are scanned and that scanning is done frequently. We recommend weekly. Your existing scanning solution or set of test tools should make this not just possible, but easy and affordable. If that is not the case, please consider AVDS.
Penetration Testing for Apache
The Vulnerabilities in Apache Running Version Prior to 2.2.25 is prone to false positive reports by most vulnerability assessment solutions. AVDS is alone in using behavior based testing that eliminates this issue. For all other VA tools security consultants will recommend confirmation by direct observation. In any case Penetration testing procedures for discovery of Vulnerabilities in Apache Running Version Prior to 2.2.25 produces the highest discovery accuracy rate, but the infrequency of this expensive form of testing degrades its value. The ideal would be to have pentesting accuracy and the frequency and scope possibilities of VA solutions, and this is accomplished only by AVDS.
Security Updates on Vulnerabilities in Apache Running Version Prior to 2.2.25
Given that this is one of the most frequently found vulnerabilities, there is ample information regarding mitigation online and very good reason to get it fixed. Hackers are also aware that this is a frequently found vulnerability and so its discovery and repair is that much more important. It is so well known and common that any network that has it present and unmitigated indicates “low hanging fruit” to attackers.
Disclosures related to this vulnerability
Confirming the Presence of Vulnerabilities in Apache Running Version Prior to 2.2.25
AVDS is currently tes.ting for and finding this vulnerability with zero false positives. If your current set of tools is indicating that it is present but you think it is probably a false positive, please contact us for a demonstration of AVDS.
The secret killer of VA solution value is the false positive. There was an industry wide race to find the most vulnerabilities, including Vulnerabilities in Apache Running Version Prior to 2.2.25 ,and this resulted in benefit to poorly written tests that beef up scan reports by adding a high percentage of uncertainty. This may have sold a lot of systems some years ago, but it also stuck almost all VA solutions with deliberately inaccurate reporting that adds time to repairs that no administrator can afford. Beyond Security did not participate in this race to mutually assured destruction of the industry and to this day produces the most accurate and actionable reports available.
Patching/Repairing this Vulnerability
Vulnerabilities in Apache Running Version Prior to 2.2.25 is a Medium risk vulnerability that is also high frequency and high visibility. This is the most severe combination of security factors that exists and it is extremely important to find it on your network and fix it as soon as possible.